Organization Admin Issues

Incident Report for mos

Resolved

The issue was a display inconsistency during a system migration, no service was impacted.
Posted May 13, 2026 - 13:59 BST

Identified

We are currently experiencing an issue with Organization Admin due to a conflicting logic. This has been identified and is currently being triaged by our team.
Posted May 13, 2026 - 12:39 BST
This incident affected: Organization Admin.