We're pleased to announce that the service disruption we experienced earlier has been resolved. All platform features are now fully operational.
What happened:
- We experienced a temporary service disruption - Our engineering team responded immediately to the issue - All systems have been restored and are functioning normally
What we're doing:
- Conducting a thorough review to identify the root cause - Implementing additional safeguards to prevent similar issues - Monitoring systems closely to ensure continued stability
We understand the importance of our services to your operations and apologize for any inconvenience this disruption may have caused. We appreciate your patience while we resolved this issue.
For any questions or if you continue to experience any problems, please contact our support team at support@meddicc.com
Posted Mar 18, 2025 - 20:18 GMT
Update
We're currently experiencing degraded performance across some of our platform services. While the system is operational and users can log in, you may encounter slower response times or intermittent issues while using certain features.
Posted Mar 18, 2025 - 19:22 GMT
Investigating
We are currently experiencing an outage affecting our platform. Our engineering team has been notified and is actively investigating the issue.